Question

有料記事の決済トラブル

  • サイトウケイジ
  • 有料記事の決済画面以降、下記のトラブルが発生します。

    ①有料記事の決済完了ページに記事タイトルが反映されない。
    ②決済完了画面の「購読した記事を読む」ボタンを押しても画面遷移しない。
    ③「購読した記事を読む」ボタンのアイコンが表示エラー。
    ④上記②のため、再度ホーム画面を表示し直して当該記事を選択しても購入していないことになっている。(Spriteの管理画面上は正常に決済完了している)

    プラグインOFF、キャッシュ削除を試しましたが改善しませんでした。
    お手数ですが原因をご教示いただけませんでしょうか?
    よろしくお願いいたします。

    • WP 6.4.3
    • PHP 7.4
    • JIN:R 1.3.1
    • Conoha Wing
    • GoogleChrome
    • macOS 14 Ssonoma
    2024/03/27 21:45
  • tsu_

    こんにちは!
    JIN:R運営チームのtsu_です。

    詳細のご共有ありがとうございます!

    いくつか確認させていただきたいのですが、

    ●今回の症状が出ているのは購入者全員でしょうか?
    (運営者のテスト決済では問題なく記事を見る事はできますか?)

    ●もし一部のユーザーさんのみ閲覧できない状況でしたら、デバイス状況(ブラウザの種類やバージョン情報)をお知らせいただけます幸いです

    また、閲覧できないユーザーさんのご対応はお済みでしょうか?
    もしまだでしたら、パスワード記事を設定して専用のページを作成するなどのご対応をお願いできればと思います、、

    お手数おかけしますが、ご確認よろしくお願いいたします!

    2024/03/29 10:20
  • サイトウケイジ

    ご返信ありがとうございます!
    ユーザー様へのご配慮も大変助かります!

    ご確認の内容ですが、
    ●今回の症状が出ているのは購入者全員でしょうか?
    (運営者のテスト決済では問題なく記事を見る事はできますか?)
    →今回の事象は有料記事の導入に当たり、いくつかの自前のGoogleアカウントでテスト決済をした際の事象になります。本番環境の実際の購入者は存在しません。

    ●もし一部のユーザーさんのみ閲覧できない状況でしたら、デバイス状況(ブラウザの種類やバージョン情報)をお知らせいただけます幸いです
    →いくつかの自前のGoogleアカウントで発生しましたが、ブラウザはすべてChromeです。バージョン: 123.0.6312.58(Official Build) (arm64)

    よろしくお願いいたします。

    2024/03/29 21:22
  • tsu_

    ご確認ありがとうございます!

    ユーザーさんの購入者がいらっしゃない事と、バージョンの件、承知いたしました!

    もう何点か確認させていただきたいのですが、

    ●ChromeのCookie設定はONにしているかどうか

    ●決済をする時にStripe Linkを使っているかどうか
     - Linkについてはこちらの説明がわかりやすいかもしれません↓
    https://docs.stripe.com/payments/link?locale=ja-JP

    度々お手数おかけしますが、よろしくお願いいたします!

    2024/03/30 17:11
  • サイトウケイジ

    お世話になります!
    こちらが追加のご質問への回答になります。

    ●ChromeのCookie設定はONにしているかどうか
    →いずれのアカウントでもONにしていません(初期設定の状態)

    ●決済をする時にStripe Linkを使っているかどうか
    →いずれの試行時も使っていません。

    よろしくお願いいたします。

    2024/03/30 22:56
  • tsu_

    ご回答ありがとうございます!
    なるべく近い環境を作って検証をしているのですが、同様の症状を再現できていない状態です。。

    "→いずれのアカウントでもONにしていません(初期設定の状態)"
     ↓
    お手数おかけして申し訳ないのですが、念のためChromeのCookie設定画面のスクリーンショットをご共有いただけますか??

    あと、もう1点確認していただきたい事がありまして、現状、wordpressアドレスとサイトアドレスは違うもので運用されていますか??
    CORSエラーが出ているのが気になりまして...

    ご確認よろしくお願いいたします!

    2024/03/31 23:30
  • サイトウケイジ

    ChromeのCookie設定画面のスクリーンショットを添付します。

    ご質問のアドレスについてですが、同じもので運用しています。
    こちらもスクリーンショットを添付します。

    症状について念の為再度決済を行いましたが、やはり改善は見られません。

    2024/04/01 10:31
  • tsu_

    画像ありがとうございます!

    Chrome設定 > プライバシーとセキュリティ > サードパーティ Cookie の部分のスクショもいただけますと幸いです。
    何度もお手数おかけしてしまってスミマセン、、、

    質問が続いてしまって恐縮ですが、Safari など Chrome 以外でのお支払いは試されましたか??
    (もしまだ試されていないようでしたら、プラグイン停止+キャッシュ削除した状態で検証をお願いできますでしょうか)

    2024/04/01 22:31
  • tsu_

    度々スミマセン、、、
    もう1点お願いしたい事がございます。

    以下のサイトを参考に .htaccess ファイルに追記していただけますか??
    https://btj0.com/blog/wordpress/cors-error/

    ※念の為 .htaccess ファイルの中身はバックアップを取ってから作業をお願いいたします...!

    conohaサーバーの.htaccess ファイルの設定方法もお伝えさせていただきますね↓
    https://support.conoha.jp/w/htaccess/

    2024/04/01 22:52
  • サイトウケイジ

    Chromeのサードパーティ Cookie のスクリーンショットを添付します。

    Chrome以外では決済を試したことはありませんでした。
    .htaccess ファイルに追記した後、Safariで試した結果次の状態でした。
    ・アイコンの表記は正常、
    ・決済画面の記事タイトルは反映されず
    ・「購読した記事を読む」ボタンを押しても画面遷移せず
    ・再度ホーム画面を表示し、当該記事を選択しても再度購入画面に進む

    続いて、Chromeで再度購入したところ、アイコンは表示エラーのままでした。

    よろしくお願いします。

    2024/04/02 01:35
  • tsu_

    ご検証いただき、ありがとうございます!!

    .htaccess の記述は今も残していただいている状態でしょうか??
    また、記述いただいたコードをご共有いただけますと幸いです...!

    ご確認よろしくお願いいたします。

    2024/04/02 12:32
  • サイトウケイジ

    .htaccess は追加したままです。

    2024/04/02 20:07
  • tsu_

    画像ありがとうございます!
    (確認できましたので、画像はこちらで削除させていただきますね)

    最後のblogの部分を消して、https://suzuassist.com にしてみていただけますか??

    2024/04/02 21:23
  • サイトウケイジ

    .htaccess の記述からblog部分を消した後、ChromeのCookie、キャッシュを削除して再度決済しました。

    結果
    ・アイコンの表記はエラー(試行はChrome)
    ・決済画面の記事タイトルは反映されず
    ・「購読した記事を読む」ボタンを押しても画面遷移せず
    ・再度ホーム画面を表示し、当該記事を選択しても再度購入画面に進む

    以上です。

    2024/04/02 23:03
  • tsu_

    ご連絡が遅くなってしまい申し訳ありません...
    また、ご検証ありがとうございます!

    基本的にはかなり可能性は低く、念のための確認なのですが、テスト決済をしている記事のURLには www は入ってますか??

    ※CORSエラーが気になっていたのですが、wwwありのURLではCORSエラーは出ていませんでした、、、
    (スミマセン、最初にご共有いただいていたURLがwww無しのものでしたので...)

    ご確認お願いいたします!

    2024/04/05 23:08
  • サイトウケイジ

    ご連絡ありがとうございます!

    ご指摘の点について、念の為wwwありの状態でアクセスし直して再度決済を試しました(Chrome)。結果としては症状は同様の状態で発生しました。

    ・アイコンエラー
    ・決済画面の記事タイトル表示せず
    ・決済完了画面からボタンを押しても遷移せず
    ・記事を開き直しても、再度決済画面が表示される

    何度もお手数をおかけしますが、よろしくお願いいたします。

    2024/04/06 20:15
  • tsu_

    ご確認ありがとうございます!!

    こちらの環境でも同様の症状が起きるか検証させていただきたいので、お手数をおかけしてしまいますが、テスト購入できる記事のURLをご共有いただけますでしょうか...?

    こちらでのシェアが難しいようであれば、以下のアドレスにテスト記事のURLをお知らせいただけますと幸いです。
    jinr-support@croover.co.jp

    お手数おかけしますが、よろしくお願いいたします!

    2024/04/08 12:32
  • tsu_

    度々スミマセン...!

    テスト決済のURLをご用意いただく前に、↓の記事の内容に該当しているかどうかを確認していただいても良いでしょうか...??
    https://gintachan.com/chrome-third-party-cookie-block-error/

    よろしくお願いいたします!

    2024/04/08 12:38
  • サイトウケイジ

    テスト決済記事のURLです。
    https://www.suzuassist.com/blog/area/

    確認したところ、ChromeのサードパーティCookie廃止テストの対象ではありませんでした。

    お手数ですが、ご確認よろしくお願いいたします。

    2024/04/08 18:49
  • tsu_

    URLとCookieありがとうございます!

    1点確認させていただきたいのですが、サンクスページのURLには www は入っていますか??

    ご確認お願いいたします!

    2024/04/09 16:42
  • サイトウケイジ

    確認したところ、サンクスページはwww入りでした。

    2024/04/09 17:29
  • tsu_

    あ、スミマセン、Stripe上の設定の事です!

    (画像ありがとうございます!)

    2024/04/09 22:18
  • サイトウケイジ

    Stripe上の設定ではwwwではありませんでした。

    Stripe上の設定をwwwありに編集して、記事に貼り付け直したところ、
    ・決済完了画面の記事タイトルが正常に表示
    ・決済完了画面からボタンを押すと記事にジャンプ
    ・有料部分が表示され読めるように
    と、すべてのエラーが解消されました。

    色々な可能性を教えていただきありがとうございます!
    しばらく色々な環境で確認したあと解決済みにさせていただきます。

    2024/04/09 22:57
  • tsu_

    ご確認ありがとうございます!

    お時間いただいてしまってスミマセンでした、、、
    少し様子を見つつ、また何かあればお知らせいただければと思います!

    2024/04/10 09:31
CLOSE